
1 Canon XF AMA Plug-in Guide

Avid supports Canon XF media through Avid’s Media Access (AMA) method from an Avid 
editing application.

Things You Should Know About the Canon XF AMA Plug-in
• To link to Canon XF (MPEG-2 Full HD) media, you must have both Avid MXF AMA 

Plug-in and the Canon XF AMA Plug-in installed on your system. 

• The Canon XF AMA plug-in supports both Avid Media Composer v4.0.5 and higher, 
Avid Symphony v4.0.5 and higher, and Avid NewsCutter v8.0.5 and higher.

• When released, support of Canon’s XF 300 and 305 cameras.

• Avid does not support MultiCamera editing with MXF AMA clips. 

• For additional AMA information, see www.avid.com\ama.

Canon XF Media
The Canon XF305 and Canon XF300 camera records MPEG-2 media onto compact flash 
cards. Through the Canon XF AMA plug-in and the MXF AMA plug-in, you can link to 
Canon MPEG-2 media through the AMA method.

You can edit directly from a flash card, without having to capture. You can link to a Canon 
XF flash card and reader attached to your system or copy a Canon XF flash card to the root 
of a drive.

The Canon XF AMA plug-in and the Avid MXF AMA plug-in should be installed on your 
system. To link media through the AMA method, use Link to AMA Volumes. For more 
information, see “The Avid Media Access (AMA) Workflow” on page 4 and “Linking 
Media with AMA” on page 7.

For specific Canon XF workflow steps, see “Workflow for Editing Canon XF Clips with 
AMA” on page 18.

http://www.avid.com/ama
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Canon XF Formats and Resolutions

The following table lists the formats and resolutions available when you work with GFCAM 
media:

Canon XF Files and Folders

Canon XF video and audio media files record in MXF format. 

Each card stores the video and audio files in:

• (Windows) drive:\CONTENTS\CLIPS

• (Macintosh) Macintosh HD/CONTENTS/CLIPS

n AMA does not recognize clips if the folder names in the selected path contain double-byte 
characters (DBCS). AMA recognizes folders with the directory path that includes ASCII 
alphanumeric characters.

Connecting the Canon XF Camera or CF Card Reader

You can connect the Canon XF camera or a CF card reader directly through an 
industry-standard USB 2.0 port on your computer. See the Canon XF documentation for 
information on connecting the camera or a card.

The flash card mounts as individual media drives on your desktop and then link to your Avid 
editing system through AMA.

Spanned Clips and Canon XF

Spanned clips are clips that extend from one card to another. Avid supports working with 
spanned Canon XF clips in your Avid editing application. 

Resolution/Bit Rate Raster/Frame Rate

Number of Audio 
Channels 
(maximum)

MPEG-2 HD 50 and 35Mbits
25Mbits

1920 x 1080, 1280 x 720
1440 x 1080
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Copying Canon XF Files to a FireWire or Network Drive

After you mount the flash card, you can copy the Canon XF media to a FireWire drive or a 
network drive and then eject the flash card. You might find it convenient to copy several 
flash cards to other drives so you can reuse the cards. 

You can connect a FireWire drive, for example, and store the contents of several flash cards 
on the drive so you can keep using the flash cards in the camera.

To copy the Canon XF flash cards to another drive:

1. On the drive, set up a folder for each flash card you want to copy. 

Avid recommends that you do not place the media folder at the top level of the drive.

2. Give each folder a unique name that identifies the flash card.

The name does not have to be the same as the actual flash card name.

3. Navigate to the actual flash card and select the CONTENTS folder.

4. Do one of the following: 

t Copy and paste the CONTENTS folder to the folder on the other drive.

t Click the CONTENTS folder and drag it to the folder on the other drive.

5. Eject the flash card.
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The Avid Media Access (AMA) Workflow
Avid Media Access (AMA) is a plug-in architecture that lets you link directly to clips from a 
third-party volume (for example, a P2, XDCAM or GFCAM device) or to a file based media 
clip (for example, QuickTime or MXF) into a bin without storing the media directly on your 
system. AMA lets you be more productive by browsing and editing directly from the device 
or volume.

The bin lets you log, browse, and view these clips in the usual way. Once the third-party 
device is disconnected, the bin still exists with the clips, although the media displays as 
offline. When you reconnect the device, the media appears online. The system automatically 
displays the media; you do not need to mount the drives.

The AMA method also allows for more metadata to be brought into the bin which gives you 
more information about the media. For example, essence marks (or locators) associated with 
the clip are automatically brought into your bin.

To display metadata information in your bin, see “Adding a Metadata Bin Column Heading,” 
in the Avid editing Help.

The following considerations and limitations apply:

• When the AMA setting is activated, the non-AMA method does not appear in the File 
menu. Deactivate the AMA setting to display the File > Import P2 (and Import XDCAM 
Proxy) option. The AMA setting is on by default.

• The Link to AMA File(s) menu choice is available for third-party AMA file based 
media plug-ins. To see the available AMA plug-ins available for your Avid editing 
application, go to www.avid.com\ama. You must have a third-party plug-in installed on 
your system for the option to display.

• Windows UNC (Universal Naming Convention) paths are not supported with AMA 
media. To link AMA media, map it to the drive.

• When you render an audio effect on an AMA media clip, all audio media files are 
written as PCM (MXF), regardless of what you set for the audio file format.

• The Dynamic Relink option is not supported with AMA clips.

• Avid does not support MultiCamera editing with AMA clips.

• You should not mix workflows. Either use the AMA method or use the traditional 
import/batch import method.

http://www.avid.com/ama
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Selecting the AMA Settings

You can set options in the AMA Settings dialog box to turn AMA on or off (on by default), 
to automatically mount your volumes, and to customize your bin.

To check for and download additional or updated AMA plug-ins, click the link to 
www.avid.com/ama.

To set up AMA:

1. In the Project window, click the Settings tab.

2. Double-click AMA.

The AMA Settings dialog box appears.

3. Click the Volume Mounting tab.

4. Select “Enable AMA Volume Management.”

By default, this option is selected. If you deselect the option and then reselect it, you 
must quit and restart your Avid editing application. When this option is selected, the 
File > Import menu item is no longer available.

5. If you want the system to automatically scan drives (volumes) every time, select the 
option “When mounting previously mounted volumes, do not check for modifications to 
the volume.” This option is off by default. 

http://www.avid.com/ama
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6. If you remount a volume, deselect the option “When mounting previously mounted 
volumes, do not check for modifications to the volume,” and the system checks the 
modification date of the device or drive against the last time the clips were linked. If the 
date is the same, the clips come back online. If the date is different, the system links the 
clips again, and links any new clips added to the volume. This option is off by default.

n If you restart your Avid editing application, the system automatically rescans the drives 
regardless of the options you’ve selected.

7. To customize your bin, click the Bins tab.

By default, the system links your clips into a new bin using the same name as your 
project name. If you want to change the bin name or want to use an already existing bin, 
you can make these changes in the Bins tab. 

For more information on Bins options, see “AMA Settings: Bins Tab” on page 17.

n Depending on your AMA Settings, every time you insert a card into a reader or connect a 
device, the system creates a new bin whether the same card or device has been previously 
inserted or not.

8. Click OK.

Viewing Installed AMA Plug-ins

Once you download and install a third-party plug-in from  www.avid.com/ama, you can 
enter a console command to view a list and the version number of the plug-ins installed on 
your system.

To display the list of installed AMA plugins:

1. Select Tools > Console.

2. In the command entry text box, type: AMA_ListPlugins

3. Press Enter (Windows) or Return (Macintosh).

AMA_ListPlugins displays a list of the plugins installed on your system.

http://www.avid.com/ama
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Understanding Linking with AMA

Linking lets you point to media on a device or point to the media directly on your system. 
The media physically resides on your system or it can reside on an external device. The 
device can be a camera, a card reader, an optical disk, a virtual volume on your desktop or on 
a server. The media points to the most recent source. For example, if you link the clips to a 
virtual volume on your desktop, the drive column displays the desktop as the location where 
the clips are linked to. If you then insert a card into a reader with the same media, the clips 
point to the media on the card. If you remove the card, the clips point to the media on the 
card and the clips appear offline. The card being the most recent source. Once the card is 
reinserted, the clips in the bin appear online.

Linking Media with AMA

If you link to media which originates on a volume (P2, XDCAM EX, XDCAM, or 
GFCAM), use the File > Link to AMA Volume(s) option. If you link directly to the media 
file clip (QuickTime or MXF), use the File > Link to AMA File(s) option.

n For optimum viewing and playing, Avid recommends a single clip length should not exceed 
more than 12 hours.

n The decompose option from the Clip menu is not available with AMA. You do not need to 
decompose clips when you use the AMA method.

To link clips on a volume automatically with AMA:

1. Insert a P2 card, an XDCAM EX card, an XDCAM disk, RED card, or a GFPAK into 
the device. 

The system scans the device and links the clips into a bin (based on the AMA settings).

To manually link clips from another volume with AMA:

1. Select File > Link to AMA Volumes.

The Browse For Folder dialog box opens.

2. Navigate to the P2, XDCAM, RED or GFCAM clips, and then click OK. 

For P2, navigate one level above the Contents folder. For XDCAM disks, navigate to 
one level above the Clip folder. For XDCAM EX, navigate to one level above the BPAV 
folder. For RED, navigate to the root directory of the RED card. For GFCAM, navigate 
to the root directory of the GFPAK.
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Depending if you are using an existing bin or creating a new bin, the Bin Selection 
dialog box opens. 

3. Select Bin Selection options. 

n If you relink a sequence and the bin that stores the AMA referenced clips is closed, the media 
does not relink. Before you relink, open the bin of the referenced clips.

4. Click OK.

The clips appear in the bin or bins depending on the options you selected, they highlight 
in yellow.

Option Description

Single Bin Based On Selected Folder Places all linked clips into one default bin.

Single Bin Named Lets you create a new bin and type in a new bin name. 
Places all linked clips into that bin.

Bin(s) Based on Current AMA 
Setting

Places the clips in the bin(s) you set up in the AMA 
Settings Bins tab.

Bin(s) Based on Subfolders Places the clips in bin(s) based on their subfolders.

Top Bin Window Places the clips in the active bin.



The Avid Media Access (AMA) Workflow

9

To manually link clips from a file with AMA:

1. Select File > Link to AMA File(s).

You can also right-click a bin and select Link to AMA File(s).

n The system ignores the settings you have selected in the AMA Volume Mounting settings.

2. If there is no active bin, a dialog box appears asking you to select a bin.

The Select file(s) for AMA linking dialog box opens.

3. From the AMA Plugin Filter menu, select the type of file.

4. Select the file(s) you want to link. Ctrl+click or Shift+click to select multiple files.

5. Click Open.

The clips appear in the active bin, they highlight in yellow.

If the system cannot link a file, an error message displays informing you to open the 
Console window for more information about the file(s) in error.

If you move the clip from the original drive to another drive on your system, the clip 
displays as offline in your bin.

n If you move a source file from one location to another and then back to the original location, 
you might need to refresh the bin to redisplay the clip. Close and reopen the bin to refresh 
the bin.

Option Description

All AMA Plugins Files Searches and displays all files.

QuickTime Searches and displays only QuickTime files.

MXF Searches and displays only MXF files.

RED R3D Searches and displays only RED files.
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Working with AMA Multiple Resolution Media

If you choose to link to low-resolution media, you can link to any combination of proxy or 
high-resolution audio or video media. For instance, you can link to the most compressed 
(proxy) video and the highest quality audio. 

Disks can take some time spinning up to link the high-resolution media, so linking to the 
low-resolution media saves you time. You can edit with the low-resolution media and once 
you are finished, you can relink to the high-resolution media.

At this time, Avid AMA supports linking to multiple resolution XDCAM media only.

For specific XDCAM multiple resolution workflow steps, see “Working with AMA Multiple 
Resolution Media” on page 10.

Linking to AMA Multiple Resolution Media

Before you link to low-resolution or high-resolution media, you need to select the video and 
audio quality in the AMA Settings Quality tab.

The steps below highlight linking to low-resolution media. You can also link to 
high-resolution media.

n For information about linking with AMA, see “The Avid Media Access (AMA) Workflow” on 
page 4.

To link to low-resolution media:

1. In the Project window, click the Settings tab.

2. Double-click AMA.

The AMA Settings dialog box appears.

For information about the AMA Settings, see “AMA Settings” on page 17.
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3. Click the Quality tab.

4. Click the appropriate resolution for your video in the AMA Link Preference section, and 
click OK. 

If a particular resolution is not available, it will be grayed out.

5. Insert the disk into the device.

6. Select Bin Selection options from the Bins tab.

For information on bin selection options, see “Linking Media with AMA” on page 7.

7. Select File > Link to AMA Volume.

The Browse for Folder dialog box opens.

8. Navigate to the clips, and then click OK. 

The clips appear in the bin or bins depending on the bin options you select. Clips 
highlight in yellow. 

The Video column in the bin displays the project type of the clip.
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Switching Between Multiple Resolution Media

Once you link to the low-resolution or high-resolution media and complete your edits, you 
can easily switch from low to high and high to low-resolution media. When you switch to a 
different resolution, the system replaces the clip in the bin with the new clip and resolution.

The steps below highlight switching from low-resolution to high-resolution media. You can 
also switch from high-resolution to low-resolution.

n For XDCAM, if you use the Sony PDZ-1 software to assign a User Disc ID, the Avid editing 
system displays this information in a bin column and knows what disk name is associated 
with each clip.

To switch from low-resolution to high-resolution media:

1. Insert the disk in the device.

2. Select the low-resolution clips in the bin.

3. Right-click the bin and select Modify AMA Resolutions.

The AMA Resolutions Quality dialog box appears.

4. Click the Highest Quality for your video (audio is always set to Highest Quality) and 
click OK.

The highest quality clips replace the most compressed (low-resolution) clips in the bin, 
they highlight in yellow. 

If the bin contains clips from multiple volumes, you will be prompted to insert another 
disk.
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Consolidating Multiple Resolution Media

When you are ready to move your media to shared storage, you can link to your resolution 
and consolidate at the same time.

The steps below highlight consolidating high-resolution media. You can also consolidate 
low-resolution media.

For information on why you should consolidate, see “Consolidating Media” in the Avid 
editing Help.

To consolidate high-resolution media:

1. In the Project window, click the Settings tab.

2. Double-click AMA.

The AMA Settings dialog box appears.

For information about the AMA Settings, see “AMA Settings” on page 17.

3. Click the Quality tab.

4. Click the appropriate resolution for your video in the Consolidate Preference section, 
and click OK. 

If a particular resolution is not available, it will be grayed out.
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5. To consolidate the clip, follow the steps in “Using the Consolidate Command” in the 
Avid editing Help.

The resolutions you select in the Consolidate Preference area of the AMA Settings 
Quality tab displays in the Transcode/Consolidate dialog box when you consolidate or 
transcode.

Relinking to AMA Files

After you link AMA QuickTime files into your sequence, you have the option to make 
changes (in a third party applications, such as Adobe After Effects) to that file. If you change 
the filename or change the location of the file, the best way to link that clip back into your 
sequence is through the relink option. Relinking to an AMA file allows you to link to a 
different file. This process only works if the targeted file is compatible with the old file, for 
example the file has the same duration, edit rate or number of tracks.

This feature is helpful when you have a group of linked clips that were moved to a different 
folder or drive. You can relink the clips to the new location. You can also use this feature to 
toggle between different versions of a QuickTime movie, for example a low-resolution 
version of the movie is myMovie_DV.mov and the high-resolution version of the movie is 
myMovie_1to1.mov. You can relink to both of these versions, to see which clip works better 
in your sequence.

At this time, Relink to AMA File(s) is only available with AMA QuickTime files.

To relink to an AMA QuickTime file:

1. Link to an AMA QuickTime file.

The clips highlight yellow in the bin.

For information on linking, see “Linking Media with AMA” on page 7.

2. If you then decide to change the original clip in the bin in your third-party application, 
create the new movie file.

3. In your bin, select the clip or clips you want to relink.

4. Select File > Relink to AMA File(s).

The Select file to relink AMA clip dialog box opens asking you to locate the new file.

5. Locate the new file.

If you have multiple clips selected in the bin, the system prompts you for the location of 
each file, one at a time.

6. Click Open.

The new clip highlights in the bin.

n If the new file is not compatible with the clip in the bin (it does not have the same duration, 
edit rate or number of tracks), the clip in the bin retains its original link.
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The AMA Plug-in Log File

The Avid system creates an AMA plug-in log file when you link clips. The log file records 
errors and information about the clips. If you experience any problems while you link clips 
or if you receive an error message, check the AMA log file to get more information about the 
error (for example: a corrupt file or a bad filename). You can view the log file from the 
following location on your system:

• (Windows) drive:\Program Files\Avid\Media Composer\Avid FatalError Reports. The 
name of the log file is AMALoggerMM_DD_YY.log.

• (Macintosh) Volume/Users/Shared/AvidMediaComposer/Avid FatalError Reports. The 
name of the log file is AMALoggerMM_DD_YY.log.

Using Virtual Volumes

You can use a virtual volume to copy media from a card or disk. This lets you use the card or 
disk again. A virtual volume can be a folder on your desktop or a folder located on a server. 
However, the virtual volume folder should reside one level down from the root level in order 
for the system to display it as a virtual volume. The following are examples of virtual 
volumes:

• C:\Desktop\BPAV

• Z:\P2\Card 1

• Z:\GFPAK\

With the AMA method, all drives and virtual volumes associated with your bin mount 
automatically. You cannot remove a volume while in AMA, however you can remove a 
virtual volume.

To unmount a virtual volume:

1. Choose File > Unmount.

The Unmount dialog box opens.

2. Select the virtual volume you want to remove.

3. Click OK.

The system removes the virtual volume from your system and clips linked to this virtual 
volume appear offline. When you restart your Avid editing application, the system scans 
the system for virtual volumes and the clips appear online.
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Virtual Volumes and AMA Bins

If you select Volume Name in the AMA Bin Settings tab, the system names the bin the same 
name as the virtual volume drive name. If you continue to use the same virtual volume to 
link other media through AMA, the system continues to place the linked media in the same 
bin. If you want to create a new bin for different types of media you link through AMA, you 
can either create a new virtual volume drive for each type of media (XDCAM, XDCAM EX, 
P2, GFCAM, etc.) or you can create a new bin every time you link to new media on a virtual 
volume.

To create a new bin on the same virtual volume:

1. Before you link your media through AMA, click the Settings tab in the Project window.

2. Double-click AMA. 

3. Click the Bins tab.

4. Select “Create a new bin” and specify a new bin name. 

5. Click OK.

6. Select File > Link to AMA Volumes.

The media appears in the newly created bin. Repeat these steps for each type of media.

Deleting Clips

You can delete master clips, but you cannot delete media files that reside on drives. Your 
Avid editing application treats files as read-only devices.

You can delete master clips and media files the same way you delete other master clips and 
media files. However, you might not be able to delete files that you moved rather than 
copied. If you cannot delete master clips and media files, first unlock the clips as described 
in the second procedure, and then delete them.

To delete files from cards/volumes:

1. Quit your Avid editing application.

2. On the desktop, navigate to the drive. 

3. Select the files you want to delete and press the Delete key.
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To delete files on a local drive in your Avid editing application:

1. In a bin, select the clips you want to delete.

2. (Option) Right-click and select Unlock Bin Selection.

3. Press the Delete key.

The Delete dialog box opens.

4. Select Delete master clips and Delete associated media files.

5. Click OK.

AMA Settings
AMA Settings: Bins Tab

[IDH_AMA_Settings in main heading above]

Option Description

Use active bin When this option is selected, your Avid editing application uses the currently 
active bin to store clips imported using AMA.

Create a new bin When this option is selected, your Avid editing application creates a new bin to 
store clips imported using AMA and controls the bin name. This is the default 
option.

• Default bin naming convention: uses the project name for the bin (bin name 
followed by a consecutive number).

• Volume name: the name or label of the volume (for example D:).

• Specify bin name: lets you enter a new bin name.

Display imported headframe When this option is selected, your Avid editing application displays the 
device-defined headframe.

Display editor headframe When this option is selected, your Avid editing application displays your Avid 
editing application’s headframe or frame icon in Frame view.
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AMA Settings: Volume Mounting Tab

Workflow for Editing Canon XF Clips with AMA
A typical workflow is as follows:

1. The Canon XF AMA plug-in and the MXF AMA plug-in should be installed on your 
system.

2. Mount the flash cards.

The system links the Canon XF clips automatically into a bin.

n If you use multiple flash cards and you remove one of the cards, your media displays offline.

3. Use the master clips to edit and output a sequence.

4. (Option) Rename the clips to organize your material.

5. Consolidate or transcode your sequence or clips.

The media consolidates to the destination you set in the Media Creation dialog box.

Consolidating your media helps when you work with multiple P2 cards. If a card is 
removed from the reader, consolidating lets you view your sequence with all the media 
online. 

n When you consolidate, if you want to keep your AMA clips linked to the original source, 
select the option “Keep Master clips linked to media on the original drive,” in the Copying 
Media Files dialog box. 

n  For information on consolidating your sequence, see “Consolidating Media” in the Avid 
editing Help. For information on transcoding your sequence, see “Using the Transcode 
Command” in the Avid editing Help.

6. Remove the flash card.

Option Description

Enable AMA Volume 
Management

Enables AMA linking of file-based media from supported third-party devices and 
drives. You must quit and restart your Avid editing application for the changes to take 
effect.

When mounting 
previously mounted 
volumes, do not check 
for modifications to the 
volume.

If you select this option, your Avid editing application automatically scans and links 
all clips from the third-party device and drive every time a device or drive is attached 
to your system. If you do not select this option, the system checks the modification 
date of the device or drive against the last time the clips were linked. If the date is the 
same, the clips come back online. If the date is different, the system links the clips 
again, and links any new clips added to the volume. The option is off by default.
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